Announcement

Collapse
No announcement yet.

Failed to connect to Real-Time target

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to connect to Real-Time target

    I'm having problems trying to run the FRC robot project in LabView. I've created my project, but when I click the Run button of the Robot Main VI to deploy the VI to the cRIO, I get this message:

    "Failed to connect to Real-Time target"

    I've installed the mandatory LabView, utilities, and driver station updates from http://joule.ni.com/nidu/cds/view/p/id/2261

    Please help my rookie team.

  • #2
    Re: Failed to connect to Real-Time target

    I figured out how to deploy the VI to the cRIO, but I get the following error code in my DS diagnostics tab.

    ERROR <Code>-44061 occured at "Left and Right Motors" in VI path: Robot Main.vi

    Any advice would be appreciated.
    Last edited by Jon_Bui; 02-05-2011, 02:42 AM.

    Comment


    • #3
      Re: Failed to connect to Real-Time target

      We had this same issue - the IP address of the cRIO (ie the "real-time target" for LabView) had not been set in our project in LabView.

      In LabView in the Project Explorer, right-click on "RT CompactRIO Target (10.xx.yy.02)" and select Properties. When the Properties come up, in the General category you set the "IP Address / DNS Name" field to the IP address of your cRIO. By default, it's set to "10.xx.yy.02". You replace "xx.yy" with your team number. For example, our team number is 3216, so our cRIO IP is 10.32.16.02.

      Hopefully this helps!

      Comment


      • #4
        Re: Failed to connect to Real-Time target

        One last thing to remember, Select SAVE ALL (This Project) from the FILE menu before you BUILD the program. Otherwise, you get strange errors.

        Comment

        Working...
        X