Announcement

Collapse
No announcement yet.

Question about Open2Motor VI

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question about Open2Motor VI

    Input to this VI is the PWM channel for each motor.
    My questions are:
    1. Which cRIO slot is the default for Open2Motor VI?
    2. How do you set the left motor to run from cRIO slot #4 PWM channel #10 and right motor to run from cRIO slot#6 PWM channel #10? We have the DSC’s on opposite sides of the chassis near each motor's ESC. Should I just use an Open Jaguar.VI for each motor and move on?

    TNX for your help.

  • #2
    Re: Question about Open2Motor VI

    Originally posted by jboette View Post
    1. Which cRIO slot is the default for Open2Motor VI?
    Slot 4.

    Originally posted by jboette View Post
    2. How do you set the left motor to run from cRIO slot #4 PWM channel #10 and right motor to run from cRIO slot#6 PWM channel #10? We have the DSC’s on opposite sides of the chassis near each motor's ESC. Should I just use an Open Jaguar.VI for each motor and move on?
    You would not be able to do this with the RobotDrive VIs as is. If you open the Open2MotorWithJaguar VI, you can see that it opens 2 jaguars. One solution would be to create your own copy of the Open2MotorWithJaguar and specify the slots you want (Make sure you do this in your own copy, so your changes don't get written over by the next update). The other option would be as you suggested and just use the OpenJaguar VI directly, and don't try to use the RobotDrive VIs.
    Team 330 beta tester

    Comment


    • #3
      Re: Question about Open2Motor VI

      TNX for the help.

      Comment

      Working...
      X