Announcement

Collapse
No announcement yet.

ERROR -44061 occurred at "Left and Right Motors" in the VI path: Robot Main.vi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ERROR -44061 occurred at "Left and Right Motors" in the VI path: Robot Main.vi

    My team and I are having this problem on the driver station it gives us this error with another message saying "FRC: The loop that contains RobotDrive is not running fast enough. This error can occur if the loop contains too much code, or if one or more other loops are starving the RobotDrive loop.". We don't know where we can go in Labview to fix the problem. Anybody know how to fix this problem.

  • #2
    Re: ERROR -44061 occurred at "Left and Right Motors" in the VI path: Robot Main.vi

    There is not enough detail here to solve the issue. In general that error means that you are not telling the RobotDrive object what to do frequently enough. There can be lots of sources of that:

    1. An instance or two of this error can occur on mode changes in normal working code
    2. The default autonomous code will throw this error continuously because all of the code is in disable structures so the robot won't drive unexpectedly
    3. If you place an unending loop in your teleop VI it will cause the VI to only run once and cause this error
    4. If you rename the RefNum for the RobotDrive in one place, but not in the others it may cause this.

    You will need to post more information about how you have modified the default program, what mode you are enabling the robot in, exactly what you are seeing in the DS messages, and anything else that you think may be relevant.
    FIRST®
    FRC Robotics Engineer

    Comment

    Working...
    X