Announcement

Collapse
No announcement yet.

cRIO Imaging Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cRIO Imaging Problem

    When applying the 2013 image to our cRIO, it hangs indefinitely at the "Rebooting CompactRIO device..." stage. I've tried a couple of different computers as well as different operating systems in virtual machines and install orders for the software in case the 64-bit Win8 machine I was initially on was to blame. I've also tried formatting both in safe mode and out. I've tried both connecting it directly to a computer via a patch cable (the computer is gigabit so it can auto-detect the need for crossover) and on the LAN switch. I've never tried to do this over wireless.

    Most of the time, the device doesn't seem to take an IP. Twice (out of maybe 15 attempts) it has. One time I've received an error, but usually it will just sit there for 15, 30, 60 minutes or however long I am willing to wait.

    I know the imaging tool is getting packets to the cRIO since the device does reset during that time. The tool just never detects that the reboot has finished.

    The one time I've received an error, it was this:
    Code:
    Error -2147220304 occurred at nisyscfg.lvlib:Restart.vi:1
    
    Possible reason(s):
    
    NI System Configuration:  (Hex 0x800404B0) Timeout while waiting for reboot. System is offline.
    
    
    Complete call chain:
         nisyscfg.lvlib:Restart.vi:1
         ConfigUtility.lvlib:2012_FormatSystem.vi
         ConfigUtility.lvlib:ReImageTarget.vi
         ConfigUtility.lvlib:Dialog.vi
    The cRIO is not offline during this process. Is this a known bug? Is the controller bad? There is little else I can think to try other than replacing the controller, but this is a known-good device that was working fine right before the attempt at flashing it with the 2013 image.

    Thank you

  • #2
    Re: cRIO Imaging Problem

    Welcome to the FIRST forums. It sounds like you may have already tried many of these steps, but there are some troubleshooting suggestions located at the end of this document: http://wpilib.screenstepslive.com/s/...ging-your-crio

    If you have tried all those, the fastest way to get support for this type of issue is to call NI FRC Support at 800-531-5066 (1/5/12-2/19/12) Monday through Friday 1pm-7pm CST or by posting on the NI FRC Community: https://decibel.ni.com/content/commu...ew=discussions
    FIRST®
    FRC Robotics Engineer

    Comment


    • #3
      Re: cRIO Imaging Problem

      I'm not sure what I will be able to tell them; I have to imagine they'll point me back here since the flashing tool is custom for FRC. Did NI author it?

      Comment


      • #4
        Re: cRIO Imaging Problem

        The cRIO Imaging Tool is software written by NI Engineers for FRC (as is the cRIO Image itself, the DS, Dashboard, Axis Camera Setup, and the FRC LabVIEW libraries). The support number and forum I provided are resources provided specifically for FRC teams and connect you directly with NI Application Engineers who support FRC team during the build season.

        If you prefer I can certainly assist you here, but you will likely get a faster resolution through the NI support, particularly the phone support.
        FIRST®
        FRC Robotics Engineer

        Comment

        Working...
        X